ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dominique Devienne" <>
Subject Re: svn commit: r393996 - /ant/core/trunk/src/main/org/apache/tools/ant/launch/
Date Sat, 15 Apr 2006 14:43:46 GMT
> ok, I think the consensus is that I shouldn't have committed this
> change ie -1 to this change from while -> for.

I'm also a proponent of using for loops rather than while loops for
Iterators. I picked up the idiom reading "The Java Programming
Language", and I like the added scope it provides, which is useful
since I tend to use just i (or j / k for nested loops) for the
iterator variable.

In this particular instance, it doesn't help much though, as the var
has an explicit name, the method is short, and the for loop itself is
broken down on 2 lines.

OTOH, I don't like Antoine's for loop ;-) I haven't tried, but I
wouldn't have thought it compiled either ;-))) -DD

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message