ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 31648] New: - BUILD FAILED ' does not exist in this project.
Date Mon, 11 Oct 2004 15:36:14 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=31648>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=31648

BUILD FAILED ' does not exist in this project.

           Summary: BUILD FAILED ' does not exist in this project.
           Product: Ant
           Version: 1.6.2
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Core
        AssignedTo: dev@ant.apache.org
        ReportedBy: rolf@rolf.mueller.name


If I start ant from a bash shell script, then it fails,
if I start it directly through the console, it works fine.

Here is the shell script:

#!/bin/sh
echo JAVA_HOME is set to: $JAVA_HOME
echo ANT_HOME  is set to: $ANT_HOME
echo This script will deploy IMS.Server
echo If you get a BUILD FAILED error, try to run
echo the command 'ant deploy.instances' directly.

ant -verbose deploy.instances

Running it as ./install.sh, the result is the following:

JAVA_HOME is set to: /usr/java/j2sdk1.4.2_05
ANT_HOME is set to: /usr/local/apache-ant-1.6.2
This script will deploy IMS.Server
If you get a BUILD FAILED error, try to run
the command ant deploy.instances directly.
Apache Ant version 1.6.2 compiled on July 16 2004
Buildfile: build.xml
Detected Java version: 1.4 in: /usr/java/j2sdk1.4.2_05/jre
Detected OS: Linux
parsing buildfile /var/managedimages/install.linux/build.xml with URI =
file:///var/managedimages/install.linux/build.xml
Project base dir set to: /var/managedimages/install.linux
                                                                                
BUILD FAILED
' does not exist in this project.
        at org.apache.tools.ant.Project.tsort(Project.java:1665)
        at org.apache.tools.ant.Project.topoSort(Project.java:1587)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1191)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1062)
        at org.apache.tools.ant.Main.runBuild(Main.java:673)
        at org.apache.tools.ant.Main.startAnt(Main.java:188)
        at org.apache.tools.ant.launch.Launcher.run(Launcher.java:196)
        at org.apache.tools.ant.launch.Launcher.main(Launcher.java:55)


Now, when I directly run ant, as in 'ant deploy.instances', then
the build goes through fine.

Here is some additional information about the working directory and the content:

[root@rm12 install.linux]# pwd
/var/managedimages/install.linux
[root@rm12 install.linux]# ls -al
total 28
drwxr-xr-x    2 root     root         4096 Oct 12 01:13 .
drwxr-xr-x    8 root     root         4096 Oct 12 01:05 ..
-rw-r--r--    1 root     root          335 Oct 11 23:35 build.properties
-rw-r--r--    1 root     root         7134 Oct 11 23:35 build.xml
-rwxr--r--    1 root     root          254 Oct 12 01:13 install.sh

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message