ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 26310] New: - Ant 1.6 and XDoclet 1.2 "destDir attribute must be present." error
Date Wed, 21 Jan 2004 14:07:10 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=26310>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=26310

Ant 1.6 and XDoclet 1.2 "destDir attribute must be present." error

           Summary: Ant 1.6 and XDoclet 1.2 "destDir attribute must be
                    present." error
           Product: Ant
           Version: 1.6.0
          Platform: PC
        OS/Version: Windows NT/2K
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Build Process
        AssignedTo: dev@ant.apache.org
        ReportedBy: ths@scandihealth.com


When using ant 1.6 and XDoclet 1.2 I get an error when I try to execute the 
same target twice, within one session.

When executing the target twice via the <antcall> target I don't get an error?

To illustrate I have made the following small buildfile (testbuild.xml):

<project name="AntXdocletTest" default="default">
    <description>Test ant script to verify xdoclet error.
    !You must have the XDoclet jars in the ${basedir}/lib directory!
    </description>

    <path id="main.classpath">
        <fileset dir="${basedir}/lib">
            <include name="**/*.jar"/>
	</fileset>
    </path>

    <target name="default">
	<taskdef name="doclet"
        	classname="xdoclet.DocletTask"
		classpathref="main.classpath"/>
	<doclet destDir="${basedir}">
		<fileset file="${basedir}/testbuild.xml"/>
	</doclet>		
</target>

<target name="testAntCall">
	<antcall target="default"/>
</target>
</project>

!Please note that you must have the XDoclet jars in the ${basedir}/lib.!

Testrun 1:

C:\server\java>ant -f testbuild.xml
Buildfile: testbuild.xml

default:

BUILD SUCCESSFUL
Total time: 3 seconds

Testrun 2:

C:\server\java>ant -f testbuild.xml default default
Buildfile: testbuild.xml

default:

default:
   [doclet] C:\server\java\testbuild.xml:14: destDir attribute must be present.
   [doclet]     at xdoclet.DocletTask.validateOptions(DocletTask.java:491)
   [doclet]     at xjavadoc.ant.XJavadocTask.execute(XJavadocTask.java:94)
   [doclet]     at org.apache.tools.ant.Task.perform(Task.java:401)
   [doclet]     at org.apache.tools.ant.Target.execute(Target.java:338)
   [doclet]     at org.apache.tools.ant.Target.performTasks(Target.java:365)
   [doclet]     at org.apache.tools.ant.Project.executeTarget(Project.java:1237)
   [doclet]     at org.apache.tools.ant.Project.executeTargets
(Project.java:1094)
   [doclet]     at org.apache.tools.ant.Main.runBuild(Main.java:669)
   [doclet]     at org.apache.tools.ant.Main.startAnt(Main.java:220)
   [doclet]     at org.apache.tools.ant.launch.Launcher.run(Launcher.java:215)
   [doclet]     at org.apache.tools.ant.launch.Launcher.main(Launcher.java:90)

BUILD FAILED
C:\server\java\testbuild.xml:14: Unexpected error

Total time: 4 seconds

Testrun 3:

C:\server\java>ant -f testbuild.xml default testAntCall
Buildfile: testbuild.xml

default:

testAntCall:

default:

BUILD SUCCESSFUL
Total time: 4 seconds

I have not investigated if the "dependency" error is general, ie. not just 
related to xdoclet?!

My reason for beliving it to be an Ant bug, opposed to a XDoclet bug, is that I 
can't reproduce the errors with Ant1.5.2 or Ant1.5.4

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@ant.apache.org
For additional commands, e-mail: dev-help@ant.apache.org


Mime
View raw message