ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Hatcher <>
Subject Re: problems with import task
Date Wed, 16 Jul 2003 15:32:29 GMT
On Wednesday, July 16, 2003, at 10:19  AM, Nicola Ken Barozzi wrote:
>> I'm finally getting around to trying the latest features of CVS Ant 
>> in a production environment.  The <import> task will help 
>> tremendously, no question, but I've run into a couple of issues:
>> - I tried doing to <import>'s in the same build file, and the second 
>> import failed because it could not find the file, although it appears 
>> the relative base directory is being mangled after the first import.  
>> Or am I confused and missing something here?
> Sorry, but I don't understand. Can you please post a buildfile with 
> the problem? We can then fix it and add it to the testcases.

I did this:

	<import file="../shared.xml"/>
	<import file="../shared-db.xml"/>

The second import failed because (sorry, I don't have the exact message 
handy) it could not find the file, even though it was there in the 
parent directory.

>> - Having the stuff imported *after* all the top-level items really is 
>> making things tough.  I've had to move some top-level stuff specific 
>> to my concrete project into an init target since it relies on 
>> properties set from the imported build file.  I'm guessing this is 
>> hard to fix though?
> At first it worked this way, but then something was changed. It should 
> not be hard.

I'll try Peter's recent patch to it out soon and see where things are 


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message