ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 19150] - Command-line argument "jvmarg" attribute "file" not working.
Date Wed, 23 Apr 2003 09:37:17 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=19150>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=19150

Command-line argument "jvmarg" attribute "file" not working.





------- Additional Comments From bodewig@apache.org  2003-04-23 09:37 -------
Uhm, no, this is not the problem, I'm afraid.

See this here (running ant -debug)

>   +Task: java
>     [java] Executing '/usr/local/java/jdk1.3.1_07/jre/bin/java' with
arguments:     >     [java] '/cfg/cmdline.properties'
>     [java] '-Duser.region=US'
>     [java] '-Duser.language=en'
>     [java] '-Duser.timezone=Europe/Copenhagen'
>     [java] 'org.xpse.MyMain'
>     [java] 
>     [java] The ' characters around the executable and arguments are
>     [java] not part of the command.
>Execute:Java13CommandLauncher: Executing
>'/usr/local/java/jdk1.3.1_07/jre/bin/java' with arguments:
>'/cfg/cmdline.properties'
>'-Duser.region=US'
>'-Duser.language=en'
>'-Duser.timezone=Europe/Copenhagen'
>'org.xpse.MyMain'

>The ' characters around the executable and arguments are
>not part of the command.

Looks good, doesn't it, but now ...

>     [java] Exception in thread "main" java.lang.NoClassDefFoundError:
/cfg/cmdline/properties
>     [java] Java Result: 1

It is java itself, which doesn't recognize the filename as an option (after all,
it is no valid option for the java executable) and tries to make a class name
from your filename.

I'm almost sure you wanted to use <arg> insteaf of <jvmarg> to pass the filename
as an argument to your class.

Mime
View raw message