ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 18667] - javah module no longer works with Java 1.4.2
Date Fri, 04 Apr 2003 11:11:05 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18667>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=18667

javah module no longer works with Java 1.4.2

dan.dyer@empathysoftware.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
           Severity|Normal                      |Blocker
         OS/Version|All                         |Linux
           Priority|Other                       |High
           Platform|All                         |PC
            Version|1.5                         |1.5.1



------- Additional Comments From dan.dyer@empathysoftware.com  2003-04-04 11:11 -------
I have a similar problem using Ant 1.5.1 on Linux with Java 1.4.2 beta.

java.lang.NoSuchMethodError: com.sun.tools.javah.Main.<init>([Ljava/lang/String;
)V
        at org.apache.tools.ant.taskdefs.optional.Javah.doClassicCompile(Javah.
java:348)
        at org.apache.tools.ant.taskdefs.optional.Javah.execute(Javah.java:318)
        at org.apache.tools.ant.Task.perform(Task.java:319)
        at org.apache.tools.ant.Target.execute(Target.java:309)
        at org.apache.tools.ant.Target.performTasks(Target.java:336)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
        at org.apache.tools.ant.Project.executeTargets(Project.java:1250)
        at org.apache.tools.ant.Main.runBuild(Main.java:610)
        at org.apache.tools.ant.Main.start(Main.java:196)
        at org.apache.tools.ant.Main.main(Main.java:235)

Mime
View raw message