ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 17857] New: - Doesn't work with j2sdk 1.4.1_02 ???
Date Tue, 11 Mar 2003 04:09:44 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17857>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=17857

Doesn't work with j2sdk 1.4.1_02 ???

           Summary: Doesn't work with j2sdk 1.4.1_02 ???
           Product: Ant
           Version: 1.5.2
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Core tasks
        AssignedTo: dev@ant.apache.org
        ReportedBy: jimeng@ameritech.net


I am trying to run tomcat 4.1.18 with new installs of ant 1.5.2 and j2sdk
1.4.1_02.  I keep getting errors.  It seems that Ant's CompilerAdapterFactory
class uses a number of tests to determine the compiler in use.  The
doesModernCompilerExist method is supposed to distinguish between sun javac
before 1.3 and after (I think).  Running j2sdk 1.4.1_02, I compiled and ran the
following code:

class TestComp 
{   
  public static void main(String[] arguments)
  {

     try {
            Class.forName("com.sun.tools.javac.Main");
            System.out.println("found com.sun.tools.javac.Main");
        } 
        catch (ClassNotFoundException cnfe) {
            System.out.println("did not find com.sun.tools.javac.Main");

        }
  }
}


The output from this is "did not find com.sun.tools.javac.Main".  I haven't
tested this on any other versions of the SDK, but it seems to suggest that the
test doesn't work on version 1.4.1_02.  When trying to run a webapp on Tomcat, I
get the following error messages from ANT:

Unable to find a javac compiler;
com.sun.tools.javac.Main is not on the classpath.
Perhaps JAVA_HOME does not point to the JDK
        at org.apache.tools.ant.taskdefs.compilers.CompilerAdapterFactory.getCom
piler(CompilerAdapterFactory.java:139)
        at org.apache.tools.ant.taskdefs.Javac.compile(Javac.java:833)
        at org.apache.tools.ant.taskdefs.Javac.execute(Javac.java:682)

This is followed by other error messages up the call-chain.  JAVA_HOME is
defined as C:\j2sdk1.4.1_02, which is correct.  Also C:\j2sdk1.4.1_02\bin has
been added to the path variable (as has %ANT_HOME%\bin).

This may not be an Ant bug, but I've tried lots of things and I'm hoping you
have a suggestion.

Thanks.

Jim

Mime
View raw message