ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <>
Subject Re: API changes introduced while fixing bug 10755
Date Tue, 11 Feb 2003 14:33:09 GMT
On Fri, 07 Feb 2003, Bruce Atherton <> wrote:
> At 02:28 AM 2/7/2003, Stefan Bodewig wrote:
>>One thing that I might want to see some stricter contract enforced
>>is the name.  getName() will currently return names using the
>>platform's file separator as separator for Files and forward slashes
>>for ZipEntryies.
>>I'd prefer to make that always use something predictable, and the
>>platform's separator may be the better choice.
> Depending on what you mean by "platform",

In this case, the OS.  So it would be \ on DOS based systems and / on
Unix.  The same abstraction File.separator uses.  I have no idea what
it is set to on OpenVMS.

> I think this would would not be the best choice since it makes the
> VFS layer you talked about more complicated to eventually do.

So the alternative is "always use /".  Fine with me, makes the code in
ZipScanner even easier to write.

>> > (3) New interface ResourceScanner
>>I'm not convinced that this is really needed (at this point).
> I have to agree.

So let's axe it.

>> > (4) New utility class SourceSelector.
>> >
>> > chosing some better names on the way.
>>At least I hope so.  8-)
> If the comment at the top of the file is a true indication of what
> it is for, then how about "ResourceProcessingUtils", or perhaps more
> simply "ResourceUtils".

s/process/select/ in the comment.  What about the name then?

> Is it necessary that Scanners call the logging API?

Not really.  System.err would probably work.  The problem are debug
messages that you normally would want to suppress, we can as well drop


View raw message