ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dominique Devienne <>
Subject RE: Problem with latest Selector patch?
Date Mon, 08 Jul 2002 16:42:33 GMT
Did 'cvs update', 'bootstrap', and 'build test' again this morning, on my
work machine this time (Win2K, JDK 1.4.0_01 as well, by way faster and dual
CPU), and get consistently the same failures on asserts in lines 232 & 245!
When I comment out these two lines, the DateSelectorTest completes
successfully (as does the entire Ant testsuite). Not sure what's wrong. --DD

-----Original Message-----
From: Bruce Atherton [] 
Sent: Sunday, July 07, 2002 4:19 PM
To: Ant Developers List
Subject: Re: Problem with latest Selector patch?

At 10:29 AM 7/6/2002 -0500, Dominique Devienne wrote:
>Fresh sandbox of Ant branch 1.5 from this morning. Just did bootstrap and
>build test. Win2K, JDK 1.4.0_01. --DD
>):        FAILED

Ok, I've just done a number of tests with fresh checkouts and I can't 
reproduce this error. With Win98, I have produced a different error in that looks similar, though. Here 
are the details:

     1) JDK 1.1.8 (all shells) - All selector tests pass (when basedir in 
selector.xml is adjusted)
     2) JDK 1.3.1 (all shells) - All pass
     3) JDK 1.4.0_01
         a) CMD - All pass
         b) 4NT - All pass
         c) Cygwin - fails, line 405

Windows 98:
     1) JDK 1.1.8 - All selector tests pass (when basedir in selector.xml 
is adjusted)
     2) JDK 1.4.0_01 - fails, line

Linux (Debian Woody):
     1) JDK 1.3.1 - All pass
     2) JDK 1.4.0_01 - All pass

Just to be sure this isn't intermittent, I reran the test on Win2K with JDK 
1.4.0_01 a dozen times. I ran within CMD, 4NT and Cygwin. I even tried 
removing and refetching the expected files a few times, in case it was a 
random error based on the timestamps of those, but it passed every time.

The line that is failing in the Windows 98 run is 
"fu.setFileLastModified(removeThis, 123456);", which sets the last modified 
time on a file to a specific millisecond value. That is interesting because 
the line that is failing for Dominique is comparing for a specific 
millisecond time as well - "s.setMillis(1006347300000L);". The Win2K Cygwin 
failure doesn't appear related, as the error is "expected:<d:\bar> but 

So after all this testing, I have to say that I am at a loss as to what 
Dominique is experiencing. I can comment out that particular test, but then 
we won't be exercising the setMillis() method in DateSelector.

What is the right answer? Should I nix it anyway? Also, Dominique, if you 
comment out line 232 of DateSelectorTest does everything else then work for 

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message