ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marco Hunsicker" <developm...@hunsicker.de>
Subject Accessing manifest info through AntClassLoader
Date Thu, 18 Jul 2002 17:55:20 GMT
Hi,

With a future version of my Java Source Code Formatter (this Jalopy
thingy) I plan to introduce a branding mechanism to allow compatibility
checking between the Plug-in and core runtime API versions.

It seems to me that the natural choice for such a task would be the
build-in Java versioning support (Jalopy needs Java 1.3 or later). As
Ant 2.0 will require JDK 1.2, I would suggest that AntClassLoader.java
will be extended to expose the Manifest information of the .jars it
loads.

If you can agree with me regarding this issue, I can submit a modified
version that works for my purposes. The changes are fairly minimal but
obviously requires at least JDK 1.2.

Regards,
Marco




--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message