ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cost...@covalent.net
Subject Re: [IMPORTANT!] Fix Ant 1.5 Support for JAXP [Was: XMLCatalog.java -- patch breaks bootstrap.bat Yikes!]
Date Mon, 27 May 2002 04:46:16 GMT
On Mon, 27 May 2002, Conor MacNeill wrote:

> According to the current JCP requirements I'm not sure we could 
> distribute Ant with either Xerces or Xalan since I am not aware that 
> either pass their JCP test suite (there may be some exemptions 
> negotiated for Apache that I am unaware of). If the press releases were 
> any guide, this issue should be resolved but I don't think the final 
> resolution has happened yet.

That's a question for the PMC, do you know any member ? :-)

Since Xalan is included in the JDK1.4 and is the RI, we can assume it 
passed the tests. The question is if distributing 1/2 of a spec 
impl. is ok. 

I'm not saying it isn't ok, just that we don't know.


> You know, if what you contend is true, Xerces itself could not be 
> distributed without Xalan :-)

Good argument. 

We can either ignore the problem - probably nobody will notice or 
care anyway - or just pass it to Sam.  We allways have the choice
of distributing the unmodified reference implementation from Sun
( unfortunately they haven't switched yet to xerces2 )


> If we do decide to include Xalan we need to figure out which xml-apis 
> jar to include since Xerces and Xalan appear to use different versions 
> :-( Can anyone vouch for the suitability of using Xerces with Xalan's 
> xml-apis jar or do we have to take a leap of faith?

I think I can, I worked on this for a while and I'm familiar with the 
code.  

Costin


--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message