ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 9428] New: - With "rpm mode", ant script won't pull in antlrall.jar
Date Sun, 26 May 2002 21:31:36 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9428>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=9428

With "rpm mode", ant script won't pull in antlrall.jar

           Summary: With "rpm mode", ant script won't pull in antlrall.jar
           Product: Ant
           Version: 1.4.1
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Optional Tasks
        AssignedTo: ant-dev@jakarta.apache.org
        ReportedBy: danfuzz@milk.com


In "rpm mode" it doesn't seem that the ant wrapper script will pull in anything
but a list of a few explicitly-named jar files (ant ant-optional jaxp_parser 
xml_apis). This list notably doesn't include antlrall.jar, which means one has to 
explicitly alter the CLASSPATH before calling ant (though it looks like in 1.5, 
there's at least a way to give the antlr task a new CLASSPATH).

The workaround isn't too terrible, but it'd be nice not to have to.

Thanks for listening,

-dan

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message