ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: [JPackage-devel] FW: jakarta ant 1.4.1/1.5 ant script
Date Tue, 30 Apr 2002 15:42:09 GMT
On 29 Apr 2002, Nicolas Mailhot <Nicolas.Mailhot@laposte.net> wrote:
> Le lun 29/04/2002 à 12:58, Stefan Bodewig a écrit :

>> (2) replacing
>> 
>> if [...] then
>>   command
>> fi
>> 
>> with [...] && command
>> 
>> While (2) is a question of style (and I prefer ours, YMMV), 
> 
> Well, (2) is mostly to shrunk the size of these ifs,

No strong feelings here, I still prefer indentation to show what's
going on, that's all.

>> I'm totally opposed to removing the AIX hack as it would break
>> backwards compatibilty.  People don't need to set JAVACMD on AIX
>> right now.
> 
> Well, as you've wrote it's a hack and I really don't think we should
> support all non-standard jvm layouts in the main script (plus it's a
> hellhole when you have many application scripts to support like we
> do at jpackege).

>From a jpackage point of view, you are right.  From an Ant point of
view, backwards compatibility forces us to keep the hack now and for
the foreseeable future.

> so this hack could be shared with tomcat and other java apps.

fine with me.

> If core ant jars (i.e the jaxp parser) are loaded in the classpath
> after the local classpath

Nit 1: Ant's script puts the jar from ANT_HOME/lib to the front.

> and the local classpath contains saxon jars the style task will bomb
> because it will detect the Ælfred parser first, and this parser is
> not supported.

Nit 2: Ælfred is supported in 1.5.

;-)

Cheers

        Stefan

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message