ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guillaume Rousse <rou...@ccr.jussieu.fr>
Subject Re: [JPackage-devel] FW: jakarta ant 1.4.1/1.5 ant script
Date Fri, 26 Apr 2002 13:35:54 GMT
Ainsi parlait Vendredi 26 Avril 2002 15:20, Nicolas Mailhot :
[..]
> Note that I didn't even try to integrate all the nice addons Guillaume
> put in the jpackage script, just to correct the jakarta rpm. I left this
> work for others (hint hint)
I fear to guess who :-(

OK, as ant developers requested us, i'll drop the jikes special treatment in 
jpackage script.

I do not think we should revert to original situation where compiler 
preference was included in spec file, however. IMHO, choosing a compiler 
should be done at build time, not hardcoded by packager.

Only exception is package for which we know jikes doesn't work. (fop, 
netbeans, openorb, etc...). Just using -Dbuild.compiler=modern in spec file 
is not enough is package builder has .-Dbuild.compiler=jikes in its .antrc 
:-(. How can we deal safely with this ?
-- 
Guillaume Rousse <rousse@ccr.jussieu.fr>
GPG key http://lis.snv.jussieu.fr/~rousse/gpgkey.html

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message