ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <>
Subject Re: [myrmidon] moving to new module
Date Mon, 08 Apr 2002 12:24:16 GMT
On Mon, 8 Apr 2002 20:34, Adam Murdoch wrote:
> On Mon, 8 Apr 2002 20:10, Adam Murdoch wrote:
> > - Container API, o.a.myrmidon.interfaces.*
> >
> > - Container impl, o.a.myrmidon.components.*
> Oh, one more thing.  While I'm a big fan of the test that makes sure the
> components aren't directly using each other,  it's a PITA at times.

Especially when evolving classes which is why I had yet to rename the 
DependencyTest ;)

> Particularly when there's a bunch of implementations that are all kinda the
> same.  What we need is somewhere to add abstract and reusable
> implementations,

Chuck the abstract implementations in the component hierarchy. So say we have 
something like

Does that work for you?

> and util classes. 

If the util classes are part of the communication layer between the component 
and it's clients then chuck them in

So you may have FooParam, FooException etc all in that part.

> Should we stick with adding them under
> interfaces? 

That would be my vote.

> My preferred option is to add 'em alongside the interfaces, but go with a
> new package hierarchy, rather than myrmidon.interfaces.*.

Kool - what would you suggest?


is meant to represent all the classes that are required for one component to 
talk to another component. "interfaces" is a good name for it maybe but I 
guess it can be confusion as it includes both classes and java interfaces. 
How about myrmidon.roles.* ? Or something. I would still prefer 
myrmidon.interfaces.* but if there is something that can carry the same 
meaning but clearer then all the better.



| The student who is never required to do what   |
|  he cannot do never does what he can do.       |
|                       - John Stuart Mill       |

To unsubscribe, e-mail:   <>
For additional commands, e-mail: <>

View raw message