ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 6564] New: - pathconvert - map not working
Date Wed, 20 Feb 2002 01:00:22 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=6564>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=6564

pathconvert - map not working

           Summary: pathconvert - map not working
           Product: Ant
           Version: 1.5 alpha (nightly)
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Major
          Priority: Other
         Component: Core tasks
        AssignedTo: ant-dev@jakarta.apache.org
        ReportedBy: stevec@ignitesports.com


The <map> subelement of the <pathconvert> task does not appear to work as
advertised.

Given this build.xml:

<project name="test" default="testtarget">
<property name="dist.dir" value="/build" />
<target name="testtarget">
      <pathconvert targetos="windows" property="p1" >
         <path>
            <pathelement location="${dist.dir}" />
         </path>
         <map from="/" to="c:\"/>
      </pathconvert>
      <echo message="mapped ${dist.dir} ==> ${p1}"/>
</target>      
</project>

I get the following output:

E:\> ant
Buildfile: build.xml

testtarget:
     [echo] mapped /build ==> E:\build

BUILD SUCCESSFUL
Total time: 1 second

Given the script above, shouldn't the result be "c:\build"?

--
To unsubscribe, e-mail:   <mailto:ant-dev-unsubscribe@jakarta.apache.org>
For additional commands, e-mail: <mailto:ant-dev-help@jakarta.apache.org>


Mime
View raw message