Thanks for the reply.

How did you debug this?
I have files in the repository that have numbers in their names, but I am not sure if this is the problem.
I have looked at the pvcs*log file and this contains all the filenames that it should.

Also is it possible to specify folders in a project to do a get on?


-----Original Message-----
From: []
Sent: Wednesday, May 23, 2001 7:34 PM
To: ''
Subject: Re: PVCS optional task error

I had the same error, if not the same problem.  I was hoping to submit a
patch tomorrow.

In my case, can't speak to yours, the filename had a "(1)" in the
name.  The code uses a MessageFormat that looks for "{0}({1})" so it found
the wrong match.  It then tried to process the "1" as a directory and
puked.  The quick change I made was to add a "-arc" to the
format: "{0}-arc({1})".  Or something similiar, sorry the code is at
work.  This allowed it to match through the path name, to the ) in the
filename.  These names are in a pvcs*log file in the directory.  This is
then passed to the get command.  In my case, the get command didn't like
the "()"s either, and skipped the offending files. 

If this doesn't help, it might at least point you in the right direction.

On Wed, 23 May 2001, Philpott, Gregory (CRTUSW) wrote:

> Hi
> I am using Windows NT 4.0, JDK1.2.2, ant-1.4-alpha (23May2001) with the
> optional tasks (23 May2001) and Merant PVCS 6.6.10.
> my build.xml looks like this:
> ---------------------------------------------
> <project name="test" default="getlatest">
>       <target name="getlatest">
>               <pvcs repository="K:/myrepository" />
>       </target>
> </project>
> ----------------------------------------------
> and the output from running ant at the command line is:
> ----------------------------------------------
> C:\TEMP\test>ant
> Buildfile: build.xml
> getlatest:
>      [pvcs] PVCS Version Manager (VMGUI) v6.6.10 (Build 870) for Windows
> NT/80x86
>      [pvcs] Copyright 1985-2000 MERANT.  All rights reserved.
> java.lang.StringIndexOutOfBoundsException: String index out of range: -1
>         at java.lang.String.substring(, Compiled Code)
>         at
> Source)
>         at
> Source)
>         at, Compiled Code)
>         at
>         at, Compiled
> Code)
>         at,
> Compiled Code)
>         at, Compiled Code)
>         at
> Total time: 2 minutes 26 seconds
> String index out of range: -1
> -------------------------------------------------
> Does anyone know how to resolve this problem?
> Thanks,
> Greg