ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 1277] Changed - Apply fails when there are no input files
Date Mon, 09 Apr 2001 22:49:23 GMT
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=1277

*** shadow/1277	Mon Apr  9 15:40:46 2001
--- shadow/1277.tmp.21905	Mon Apr  9 15:49:22 2001
***************
*** 4,11 ****
  |        Bug #: 1277                        Product: Ant                     |
  |       Status: NEW                         Version: 1.3                     |
  |   Resolution:                            Platform: Macintosh               |
! |     Severity: Normal                   OS/Version: MacOS X                 |
! |     Priority:                           Component: Core tasks              |
  +----------------------------------------------------------------------------+
  |  Assigned To: ant-dev@jakarta.apache.org                                   |
  |  Reported By: cholmes@4d.com                                               |
--- 4,11 ----
  |        Bug #: 1277                        Product: Ant                     |
  |       Status: NEW                         Version: 1.3                     |
  |   Resolution:                            Platform: Macintosh               |
! |     Severity: Enhancement              OS/Version: MacOS X                 |
! |     Priority: High                      Component: Core tasks              |
  +----------------------------------------------------------------------------+
  |  Assigned To: ant-dev@jakarta.apache.org                                   |
  |  Reported By: cholmes@4d.com                                               |
***************
*** 25,28 ****
  code of 1.
  
  IMHO, apply should either 1) not return an error when a fileset is empty or 
! 2) provide a "failOnEmptyFileset" attribute.
--- 25,51 ----
  code of 1.
  
  IMHO, apply should either 1) not return an error when a fileset is empty or 
! 2) provide a "failOnEmptyFileset" attribute.
! 
! ------- Additional Comments From cholmes@4d.com  2001-04-09 15:49 -------
! Ok, I just realized that a big part of the problem is that gcc returns 1 when 
! 
! the fileset is empty -- it isn't exactly a bug with Apply.  (Note to self: knock 
! 
! self in head with heavy object for 5 minutes this afternoon.)  But I've seen 
! 
! identical behavior whenever I run Apply, so this is a common problem.  
! 
! 
! 
! So I have a new suggestion: provide a "runOnEmptyFileset" or similar 
! 
! attribute which will let you skip the empty ones, thus avoiding these 
! 
! errors.
! 
! 
! 
! In light of this, I'm changing the severity of this bug to "Enhancement" (if 
! 
! the bugbase lets me).

Mime
View raw message