ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vincent Massol" <vmas...@octo.fr>
Subject Re: Problem with latest CVS Ant and Zips
Date Sun, 25 Mar 2001 18:10:24 GMT

----- Original Message -----
From: "Stefan Bodewig" <bodewig@apache.org>
To: <ant-dev@jakarta.apache.org>
Sent: Friday, March 23, 2001 4:13 PM
Subject: Re: Problem with latest CVS Ant and Zips


> Vincent Massol <vmassol@octo.fr> wrote:
>
> >> What does a command line ZIP utility or jar say about the created
> >> war archive, does it detect any problems?
> >
> > I checked the war file using Winzip 8.0 and it opens fine. When I
> > run the tests, no error is reported and everything seems fine.
> >
> > I agree it is strange. I verified 3 times to make sure I was not
> > making it up but it seems it is real.  What can I do to help debug
> > this ?
>
> To be honest, I don't know.
>
> If the archive is OK (better try with jar -tf, as Sun's Java
> implementation reports errors on some files that are absolutely OK
> when handled with zlib programs - as WinZip is AFAIK), the error must
> be with Orion.
>

1/ I tried with jar -tf and no error reported
2/ I downloaded the ant 1.3 sources and recompiled everything. It worked
3/ I CVS-updated my 1.4alpha sources and recompiled everything. It failed
4/ I copied the following files from 1.3 sources to my 1.4alpha sources :
War.java, Jar.java, Zip.java, ZipFileSet.java, ZipScanner.java. I recompiled
everything. It failed !

Conclusions so far :
- Something was changed from Ant 1.3 to the current sources that lead to
this behaviour
- Apart from the files mentionned above, I really don't know which modified
files could be involved ? Any idea would help a lot.
- I am completely stuck ... ! and am going to go crazy soon ... :-)

thanks.

> Stefan
>

Vincent


Mime
View raw message