ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 413] Changed - ant exec command fails with jdk1.3 BugRat Report#715
Date Sun, 18 Feb 2001 14:26:55 GMT
http://nagoya.apache.org/bugzilla/show_bug.cgi?id=413

*** shadow/413	Thu Feb  1 15:54:46 2001
--- shadow/413.tmp.29527	Sun Feb 18 06:26:55 2001
***************
*** 41,44 ****
  I get another error-number (193), but the result is the same. It does not work 
  to execute perl-scripts using exec, even if it's possible to execute them on 
  the command-line without specifying perl.exe. Does not work for me with any JDK 
! I tried (1.1.7, 1.1.8 (IBM), 1.2.2, 1.3, 1.3 (IBM)) - all on W2K with SP1.
--- 41,53 ----
  I get another error-number (193), but the result is the same. It does not work 
  to execute perl-scripts using exec, even if it's possible to execute them on 
  the command-line without specifying perl.exe. Does not work for me with any JDK 
! I tried (1.1.7, 1.1.8 (IBM), 1.2.2, 1.3, 1.3 (IBM)) - all on W2K with SP1.
! 
! ------- Additional Comments From conor@cortexebusiness.com.au  2001-02-18 06:26 -------
! I think someone mentioned that this is because JDK uses createProcess rather 
! than ShellExec. Whatever the details, this appears to be JDK behaviour and not 
! Ant specific. 
! 
! In some cases, the non JDK 1.3 command launcher works better on NT since it 
! effectively runs the command using cmd. Should we consider not making the 1.3 
! launcher the default for NT.

Mime
View raw message