ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nelson, Laird" <Laird.Nel...@time0.com>
Subject RE: More javac problems
Date Mon, 24 Jul 2000 13:24:29 GMT
> -----Original Message-----
> From: Jim Stallard [mailto:Jim.Stallard@globalone.net]
> has anyone resolved your problem? I have the same problem also.

Well, no, not really; I took that to mean I should hack furiously at the
source code, which I'm in the process of doing.  :-)

The one suggestion I got, namely to use an include attribute with a value of
**/*.java, doesn't work because of the other problem I mentioned in another
email, viz. that of CVS/Base .java files being picked up by this as well.

There's basically no way to shut the silly thing up without patching the
code.  :-)

Additionally, my second (or third? :-)) problem was never addressed, and I
can't track down why it's happening.  I've reproduced it below.

> > When I ant this, I get:
> >
> >   cd c:/src/java/anttest/
> >   ant
> >   Buildfile: build.xml
> >
> >   init:
> >
> >   compile:
> >       [javac] Compiling 1 source files to C:\src\java\anttest\build
> >
> >   BUILD SUCCESSFUL
> >
> >   Total time: 2 seconds
> >
> > ...which is fine.  When I ant this again without touching or saving
> > anything, I get the same output.  And again, and again.  I 
> was under the
> > impression that the javac task would not recompile things 
> that don't need to
> > be recompiled, but this appears to be false.  Can someone 
> please verify this
> > problem?  How do I make the javac task only compile those 
> things that need
> > to be compiled?

Cheers,
Laird

Mime
View raw message