ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ken Wood <>
Subject Re: cvs commit:jakarta-ant/src/main/org/apache/tools/ant/taskdefs
Date Sun, 16 Jul 2000 02:47:11 GMT
Yea, I thought about that 10 seconds after I hit
'send', so I changed the source path to "com",
which was closer, but still not right.

After your message, I changed it to "./" and
it STILL didn't work, but it found a WHOLE
lot more files it could not evaluate the
package for, and then it croaked...again,
because there were no packagenames passed
to javadoc. Something tells me I could just
fork a JVM with the right commands and
it would work (since it's working in a Makefile...)
but Ant is doing some pre-processing, and either
I'm not invoking it right, or it's losing track of what
it's doing as it pre-processes....

Peter Donald wrote:

> At 03:09  15/7/00 -0500, you wrote:
> >Javadoc still doesn't work for me (I grabbed the lastest copy today)
> I think I see the problem
> > [javadoc] Javadoc args: [-J-Xmx1024m,
> >-classpath, /opt/jdk1.2.1/jre/lib/rt.jar: <SNIP>...,
> >-sourcepath, com/i2/gs:com/i2/rcp,
> sourcepath should point to the base of your hierarchy. So if your classes
> happen to be in src/com/i2/rcp your sourcepath has to be src/. Try that and
> see if that works
> Cheers,
> Pete
> *------------------------------------------------------*
> | "Nearly all men can stand adversity, but if you want |
> | to test a man's character, give him power."          |
> |       -Abraham Lincoln                               |
> *------------------------------------------------------*

View raw message