ant-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phil Hanna" <aut...@philhanna.com>
Subject Re: ant target attribute not working
Date Mon, 10 Jul 2000 03:32:49 GMT
No, I'm on JDK1.3 rc2 in both places.  I still have the June 1 code, and I
recompiled it just now to see that it still works (it does).

I tested the logic in ProjectHelper in isolation, and it shows that the
setTarget(String) method is overlooked by the
beanInfo.getPropertyDescriptors() method:

import java.beans.*;
import java.io.*;
import java.lang.reflect.*;
import java.net.*;
import java.util.*;

public class PropertyTester
{
   public static void main(String[] args)
      throws Exception
   {
      Class targetClass =
Class.forName("org.apache.tools.ant.taskdefs.Ant");
      BeanInfo beanInfo = Introspector.getBeanInfo(targetClass);
      PropertyDescriptor[] pda = beanInfo.getPropertyDescriptors();
      for (int i = 0; i < pda.length; i++) {
         PropertyDescriptor pd = pda[i];
         String property = pd.getName();
         Method setMethod = pd.getWriteMethod();
         System.out.println("property=" + property + ",setMethod=" +
setMethod);
      }
   }
}

----- Original Message -----
From: <donaldp@mad.scientist.com>
To: <ant-dev@jakarta.apache.org>
Sent: Sunday, July 09, 2000 11:19 PM
Subject: Re: ant target attribute not working


> Hi,
>
> Have you changed jvms in the time between ? The reflection
> apis changed between 1.1/1.2 with regards to order of
> entries in .class files which means if it relied on 1.1
> ordering it would break in 1.2 ? Could that be it ?
>
>
>


Mime
View raw message