allura-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Riegel <crie...@gmail.com>
Subject allura email
Date Wed, 15 May 2013 14:05:38 GMT
>From a high level, what would be needed to get email working in allura?

For example (sending email), when a user tries to claim an email address on
their preferences page, I see the confirmation email and link to the
confirmation url in allura.log but an there's an error message in taskd.log:

Error on job <MonQTask 5193893b100d2b0628ad4fe0 (busy) P:10
allura.tasks.mail_tasks.sendmail vagrant-ubuntu-precise-64 pid 1572
project:None app:None user:root>, re-raising it

I'm curious how this fit in with forgemail and lamson and what direction
you think might be best to build this in to allura based on your lessons
learned.  I'm expecting you have some external mechanism to facilitate this
on sf.net.


Going the other way (receiving email), I've edited development.ini and
updated smtp_server and smtp_port for my setup, confirmed that my port is
open, executed "paster smtp_server ../../development.ini" in the
allura/command directory, and tried sending email to
blog@adobe.smtp_serverand wiki@adobe.smtp_server(where smtp_server is
what I placed in development.ini and the adobe
neighborhood has wiki and blog apps).  However, the emails fail and get
returned with DNS errors for domain not found, so I've been playing with my
MX records, but those seem to be ok.  I'm just looking for confirmation
that what I've done sounds like the correct process or if I've missed
something on the server setup.

Thanks!

Mime
View raw message