Eugène,

Our requirements actually list WebOb 1.0.8 (in requirements-common.txt), which is what we use at SourceForge and what we've tested with and can confirm works.  The 1.1.1 requirement appears to be coming from WebTest, indicating you have a higher version than the 1.4.0 specified in requirements-common.txt, yet not the newest version which specifies >= 1.2 for WebOb.

If you wish to try running with WebOb 1.2.3, you could try upgrading your WebTest version, but since we haven't tested with those versions, I can't say that it will work without further error.  My recommendation would be to downgrade WebTest to 1.4.0 and WebOb to 1.0.8 but I don't know of any specific issues with the newer versions that would cause issues, so it may be worth a try.


- Cory


On Sun, Apr 14, 2013 at 4:04 PM, Eugène Adell <Eugene.Adell@d2-si.eu> wrote:
Hello

when installing Allura, I get an error at this step :


$ python setup.py develop

error: Installed distribution WebOb 1.2.3 conflicts with requirement WebOb==1.1.1


Do I need to force an install with WebOb 1.1.1 ?