allura-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eugène Adell <Eugene.Ad...@d2-si.eu>
Subject RE:WebOb conflict
Date Tue, 23 Apr 2013 17:25:03 GMT


Hi all

it's still not good, maybe are there other packages which behave like numpy ? The new logs
are here : http://95.154.250.47/alluralogs/

I notice that the pip install fails with a gcc compil.

It's not possible to use the Vagrant image on my server and it would be nice to have the "normal"
install process working well

Again, thanks for helping.


De : Cory Johns [cjohns@slashdotmedia.com]
Envoyé : lundi 22 avril 2013 17:05
À : allura-users@incubator.apache.org
Objet : Re: WebOb conflict


Eugène, 


Your pip log shows it failing when installing matplotlib which is causing Pylons to get skipped.
 Tim tells me that this is an issue with pip trying to install matplotlib before numpy, even
though numpy is in the file first.  The work-around is to manually running `pip install numpy==1.6.1`
in the virtualenv before running `pip install -r requirements.txt`.


Sorry for the difficulty on this one.  You could also try using the Vagrant image that Tim
posted in another thread.



On Fri, Apr 19, 2013 at 4:55 PM, Eugène Adell <Eugene.Adell@d2-si.eu> wrote:

Hello,
still bad when trying your method.

After mkvirtualenv it seems ok :

# pip freeze
argparse==1.2.1
wsgiref==0.1.2

After " pip install -r requirements.txt " the freeze command returns the same result as before.
But during "python setup.py develop", the problem occurs. The freeze then returns this :

# pip freeze

Warning: cannot find svn location for Ming==0.3.3dev-20130322

Warning: cannot find svn location for EasyWidgets==0.2dev-20130116

Allura==0.1dev
Babel==0.9.6
BeautifulSoup==3.2.1
Creoleparser==0.7.4
## FIXME: could not find svn URL in dependency_links for this package:
EasyWidgets==0.2dev-20130116
FormEncode==1.2.6
Jinja2==2.6
Markdown==2.3.1
## FIXME: could not find svn URL in dependency_links for this package:
Ming==0.3.3dev-20130322
PIL==1.1.7
Pygments==1.6
Pylons==1.0.1
Pypeline==0.1dev
TurboGears2==2.2.2
WebError==0.10.3
WebFlash==0.1a9
WebHelpers==1.3
WebOb==1.2.3
WebTest==2.0.5
argparse==1.2.1
chardet==2.1.1
crank==0.6.4
datadiff==1.1.5
docutils==0.10
feedparser==5.1.3
httplib2==0.8
iso8601==0.1.4
mock==1.0.1
nose==1.3.0
oauth2==1.5.211
pymongo==2.5
pysolr==3.0.6
python-dateutil==2.1
python-openid==2.2.5
requests==1.2.0
textile==2.1.5
wsgiref==0.1.2

I put the two logs coming from "pip install" and "python setup.py" here : http://95.154.250.47/alluralogs/

Thanks a lot






De : Cory Johns [cjohns@slashdotmedia.com]
Envoyé : vendredi 19 avril 2013 15:33

À : allura-users@incubator.apache.org
Objet : Re: WebOb conflict


I'm really at a loss here, as I tested the build myself on a fresh virtualenv created with:


    [cjohns allura]$ mkvirtualenv test-allura --no-site-packages
    New python executable in test-allura/bin/python27
    Also creating executable in test-allura/bin/python
    Installing setuptools............done.
    [cjohns allura]$ workon test-allura
    (test-allura)[cjohns allura]$ pip freeze
    wsgiref==0.1.2

    (test-allura)[cjohns allura]$ pip install -r requirements.txt
...
    (test-allura)[cjohns allura]$ pip freeze | egrep 'Pylons|WebOb'
    Pylons==1.0
    WebOb==1.0.8


Other than a build error on matplotlib, everything went as expected and I ended up with the
expected versions.


My advice would be to ensure that you start with a fresh virtualenv with --no-site-packages
explicitly stated, ensure it has no unexpected initial packages via pip freeze, and perform
the pip install -r requirements.txt before installing any additional libraries.



On Thu, Apr 18, 2013 at 5:49 AM, Eugène Adell <Eugene.Adell@d2-si.eu> wrote:


I get the same problem on a fresh VM with a fresh virtualenv. I am following this doc :

https://sourceforge.net/p/allura/git/ci/master/tree/README.markdown

Now, the error looks like this :

...
Searching for Pylons
Reading http://pypi.python.org/simple/Pylons/
Reading http://www.pylonshq.com/
Best match: Pylons 1.0.1
Downloading http://pypi.python.org/packages/source/P/Pylons/Pylons-1.0.1.tar.gz#md5=6cb880d75fa81213192142b07a6e4915
Processing Pylons-1.0.1.tar.gz
Running Pylons-1.0.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install-7xHulp/Pylons-1.0.1/egg-dist-tmp-nBfo7J
warning: no previously-included files matching '*' found under directory 'tests/test_units/session'
warning: no previously-included files matching '.DS_Store' found anywhere in distribution
warning: no previously-included files matching '*.hgignore' found anywhere in distribution
warning: no previously-included files matching '*.hgtags' found anywhere in distribution
Adding Pylons 1.0.1 to easy-install.pth file

Installed /root/anvil/lib/python2.7/site-packages/Pylons-1.0.1-py2.7.egg
Reading http://www.pylonshq.com/download/1.0

error: Installed distribution WebOb 1.2.3 conflicts with requirement WebOb==1.1.1




________________________________________
De : Cory Johns [cjohns@slashdotmedia.com]
Envoyé : mardi 16 avril 2013 16:20

À : allura-users@incubator.apache.org
Objet : Re: WebOb conflict


Dave makes a good point.  Instead of trying to triage specific version conflicts, a better
approach would be to create a fresh virtualenv (making sure not to include site packages,
although that's been the default behavior for a while; but you might want to check your virtualenv
/ mkvirtualenv version just to be sure) and then install just the required libraries with:

  pip install -r requirements.txt

As Dave mentioned, the README file has more detailed instructions.



On Mon, Apr 15, 2013 at 5:55 PM, Dave Brondsema <dave@brondsema.net<mailto:dave@brondsema.net>>
wrote:
Hey Eugène, just wondering did you install with a fresh python virtual
environment and the requirements.txt file?  If you follow the instructions in
the README to do that I don't think you'd have any version errors.

On 4/15/13 2:06 PM, Eugène Adell wrote:
>
> Still not good, is there any way to find the root cause ? Again, thanks for helping
>
> # pip list
> Allura (0.1dev)
> argparse (1.2.1)
> Babel (0.9.6)
> Beaker (1.6.4)
> BeautifulSoup (3.2.1)
> beautifulsoup4 (4.1.3)
> chardet (2.1.1)
> crank (0.6.4)
> Creoleparser (0.7.4)
> datadiff (1.1.5)
> decorator (3.4.0)
> docutils (0.10)
> Warning: cannot find svn location for EasyWidgets==0.2dev-20130116
> EasyWidgets (0.2dev-20130116)
> feedparser (5.1.3)
> ForgeWiki (0.0dev)
> FormEncode (1.2.6)
> httplib2 (0.8)
> iso8601 (0.1.4)
> Jinja2 (2.6)
> Mako (0.8.0)
> Markdown (2.3.1)
> MarkupSafe (0.15)
> Warning: cannot find svn location for Ming==0.3.3dev-20130322
> Ming (0.3.3dev-20130322)
> mock (1.0.1)
> nose (1.3.0)
> oauth2 (1.5.211)
> PIL (1.1.7)
> Pygments (1.6)
> Pylons (1.0)
> pymongo (2.5)
> Pypeline (0.1dev)
> pysolr (3.0.6)
> python-dateutil (2.1)
> python-openid (2.2.5)
> repoze.lru (0.6)
> requests (1.2.0)
> Routes (1.13)
> simplejson (3.1.3)
> Tempita (0.5.1)
> textile (2.1.5)
> TurboGears2 (2.2.2)
> waitress (0.8.2)
> WebError (0.10.3)
> WebFlash (0.1a9)
> WebHelpers (1.3)
> WebOb (1.0.8)
> WebTest (1.4.0)
> wsgiref (0.1.2)
>
>
> # python setup.py develop
> running develop
> running egg_info
> writing paster_plugins to Allura.egg-info/paster_plugins.txt
> writing requirements to Allura.egg-info/requires.txt
> writing Allura.egg-info/PKG-INFO
> writing top-level names to Allura.egg-info/top_level.txt
> writing dependency_links to Allura.egg-info/dependency_links.txt
> writing entry points to Allura.egg-info/entry_points.txt
> reading manifest file 'Allura.egg-info/SOURCES.txt'
> reading manifest template 'MANIFEST.in'
> warning: no files found matching 'allura/public/favicon.ico'
> writing manifest file 'Allura.egg-info/SOURCES.txt'
> running build_ext
> Creating /root/anvil/lib/python2.7/site-packages/Allura.egg-link (link to .)
> Allura 0.1dev is already the active version in easy-install.pth
> Installed /root/src/allura/Allura
> Processing dependencies for Allura==0.1dev
> error: Installed distribution WebOb 1.0.8 conflicts with requirement WebOb==1.1.1
>
>
>

> De : Cory Johns [cjohns@slashdotmedia.com<mailto:cjohns@slashdotmedia.com>]

> Envoyé : lundi 15 avril 2013 19:06

> À : allura-users@incubator.apache.org<mailto:allura-users@incubator.apache.org>

> Objet : Re: WebOb conflict
>
>
> It looks like the conflict is coming from your version of Pylons.  We're using 1.0, while
you appear to have 1.0.1 installed.  That .0.1 release apparently updated quite a few requirements.
>
>
>

> On Mon, Apr 15, 2013 at 12:40 PM, Eugène Adell <Eugene.Adell@d2-si.eu<mailto:Eugene.Adell@d2-si.eu>>
wrote:
>
>
> Hello
>
> thanks ; after downgrading I still got a conflict error :
>
> # pip list
> Allura (0.1dev)
> argparse (1.2.1)
> Babel (0.9.6)
> BeautifulSoup (3.2.1)
> beautifulsoup4 (4.1.3)
> chardet (2.1.1)
> crank (0.6.4)
> Creoleparser (0.7.4)
> datadiff (1.1.5)
> docutils (0.10)
> Warning: cannot find svn location for EasyWidgets==0.2dev-20130116
> EasyWidgets (0.2dev-20130116)
> feedparser (5.1.3)
> ForgeWiki (0.0dev)
> FormEncode (1.2.6)
> httplib2 (0.8)
> iso8601 (0.1.4)
> Jinja2 (2.6)
> Markdown (2.3.1)
> Warning: cannot find svn location for Ming==0.3.3dev-20130322
> Ming (0.3.3dev-20130322)
> mock (1.0.1)
> nose (1.3.0)
> oauth2 (1.5.211)
> PIL (1.1.7)
> Pygments (1.6)
> Pylons (1.0.1)
> pymongo (2.5)
> Pypeline (0.1dev)
> pysolr (3.0.6)
> python-dateutil (2.1)
> python-openid (2.2.5)
> requests (1.2.0)
> textile (2.1.5)
> TurboGears2 (2.2.2)
> waitress (0.8.2)
> WebError (0.10.3)
> WebFlash (0.1a9)
> WebHelpers (1.3)
> WebOb (1.0.8)
> WebTest (1.4.0)
> wsgiref (0.1.2)
>
>
> # python setup.py develop
> running develop
> running egg_info
> writing paster_plugins to Allura.egg-info/paster_plugins.txt
> writing requirements to Allura.egg-info/requires.txt
> writing Allura.egg-info/PKG-INFO
> writing top-level names to Allura.egg-info/top_level.txt
> writing dependency_links to Allura.egg-info/dependency_links.txt
> writing entry points to Allura.egg-info/entry_points.txt
> reading manifest file 'Allura.egg-info/SOURCES.txt'
> reading manifest template 'MANIFEST.in'
> warning: no files found matching 'allura/public/favicon.ico'
> writing manifest file 'Allura.egg-info/SOURCES.txt'
> running build_ext
> Creating /root/anvil/lib/python2.7/site-packages/Allura.egg-link (link to .)
> Allura 0.1dev is already the active version in easy-install.pth
> Installed /root/src/allura/Allura
> Processing dependencies for Allura==0.1dev
> error: Installed distribution WebOb 1.0.8 conflicts with requirement WebOb==1.1.1
>
>
>
>
>
>

> De : Cory Johns [cjohns@slashdotmedia.com<mailto:cjohns@slashdotmedia.com>]

> Envoyé : lundi 15 avril 2013 18:01

> À : allura-users@incubator.apache.org<mailto:allura-users@incubator.apache.org>

> Objet : Re: WebOb conflict
>
>
>
> Eugène,
>
>
>
> Our requirements actually list WebOb 1.0.8 (in requirements-common.txt), which is what
we use at SourceForge and what we've tested with and can confirm works.  The 1.1.1 requirement
appears to be coming from WebTest, indicating you have a higher version than the 1.4.0 specified
in requirements-common.txt, yet not the newest version which specifies >= 1.2 for WebOb.
>
>
> If you wish to try running with WebOb 1.2.3, you could try upgrading your WebTest version,
but since we haven't tested with those versions, I can't say that it will work without further
error.  My recommendation would be to downgrade WebTest to 1.4.0 and WebOb to 1.0.8 but I
don't know of any specific issues with the newer versions that would cause issues, so it may
be worth a try.
>
>
>
>
> - Cory
>
>
>

> On Sun, Apr 14, 2013 at 4:04 PM, Eugène Adell <Eugene.Adell@d2-si.eu<mailto:Eugene.Adell@d2-si.eu>>
wrote:
>
> Hello
>
> when installing Allura, I get an error at this step :
>
>
> $ python setup.py develop
>
> error: Installed distribution WebOb 1.2.3 conflicts with requirement WebOb==1.1.1
>
>
> Do I need to force an install with WebOb 1.1.1 ?
>



--

Dave Brondsema : dave@brondsema.net<mailto:dave@brondsema.net>

http://www.brondsema.net : personal
http://www.splike.com : programming
              <><

Mime
View raw message