allura-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eugène Adell <>
Subject RE:WebOb conflict
Date Mon, 15 Apr 2013 16:40:44 GMT


thanks ; after downgrading I still got a conflict error :

# pip list
Allura (0.1dev)
argparse (1.2.1)
Babel (0.9.6)
BeautifulSoup (3.2.1)
beautifulsoup4 (4.1.3)
chardet (2.1.1)
crank (0.6.4)
Creoleparser (0.7.4)
datadiff (1.1.5)
docutils (0.10)
Warning: cannot find svn location for EasyWidgets==0.2dev-20130116
EasyWidgets (0.2dev-20130116)
feedparser (5.1.3)
ForgeWiki (0.0dev)
FormEncode (1.2.6)
httplib2 (0.8)
iso8601 (0.1.4)
Jinja2 (2.6)
Markdown (2.3.1)
Warning: cannot find svn location for Ming==0.3.3dev-20130322
Ming (0.3.3dev-20130322)
mock (1.0.1)
nose (1.3.0)
oauth2 (1.5.211)
PIL (1.1.7)
Pygments (1.6)
Pylons (1.0.1)
pymongo (2.5)
Pypeline (0.1dev)
pysolr (3.0.6)
python-dateutil (2.1)
python-openid (2.2.5)
requests (1.2.0)
textile (2.1.5)
TurboGears2 (2.2.2)
waitress (0.8.2)
WebError (0.10.3)
WebFlash (0.1a9)
WebHelpers (1.3)
WebOb (1.0.8)
WebTest (1.4.0)
wsgiref (0.1.2)

# python develop
running develop
running egg_info
writing paster_plugins to Allura.egg-info/paster_plugins.txt
writing requirements to Allura.egg-info/requires.txt
writing Allura.egg-info/PKG-INFO
writing top-level names to Allura.egg-info/top_level.txt
writing dependency_links to Allura.egg-info/dependency_links.txt
writing entry points to Allura.egg-info/entry_points.txt
reading manifest file 'Allura.egg-info/SOURCES.txt'
reading manifest template ''
warning: no files found matching 'allura/public/favicon.ico'
writing manifest file 'Allura.egg-info/SOURCES.txt'
running build_ext
Creating /root/anvil/lib/python2.7/site-packages/Allura.egg-link (link to .)
Allura 0.1dev is already the active version in easy-install.pth
Installed /root/src/allura/Allura
Processing dependencies for Allura==0.1dev
error: Installed distribution WebOb 1.0.8 conflicts with requirement WebOb==1.1.1

De : Cory Johns []
Envoyé : lundi 15 avril 2013 18:01
À :
Objet : Re: WebOb conflict


Our requirements actually list WebOb 1.0.8 (in requirements-common.txt), which is what we
use at SourceForge and what we've tested with and can confirm works.  The 1.1.1 requirement
appears to be coming from WebTest, indicating you have a higher version than the 1.4.0 specified
in requirements-common.txt, yet not the newest version which specifies >= 1.2 for WebOb.

If you wish to try running with WebOb 1.2.3, you could try upgrading your WebTest version,
but since we haven't tested with those versions, I can't say that it will work without further
error.  My recommendation would be to downgrade WebTest to 1.4.0 and WebOb to 1.0.8 but I
don't know of any specific issues with the newer versions that would cause issues, so it may
be worth a try.

- Cory

On Sun, Apr 14, 2013 at 4:04 PM, Eugène Adell <> wrote:


when installing Allura, I get an error at this step :

$ python develop

error: Installed distribution WebOb 1.2.3 conflicts with requirement WebOb==1.1.1

Do I need to force an install with WebOb 1.1.1 ?

View raw message