abdera-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian Moseley" <...@osafoundation.org>
Subject Re: problems setting entry content
Date Sat, 31 Mar 2007 15:14:55 GMT
On 3/31/07, Garrett Rooney <rooneg@electricjellyfish.net> wrote:

> Can you be more specific about the problem you're seeing here.  I just
> tried the basic example you talk about further down:

i'll address this in a reply to a later message in the thread.

> One particularly interesting question would be how are you trying to
> build.  Ant vs Maven might have some big implications with regard to
> the recent changes in the iri stuff, for example.

i'm using m2. the steps were:

1) svn up
2) mvn clean
3) mvn install

the build fails in the core subproject with several messages like these:

package org.apache.abdera.i18n.iri does not exist

cannot find symbol
symbol  : class IRI
location: interface org.apache.abdera.model.Categories

i remember seeing things fly by on the dev list about extracting the
iri subsystem into the jjakarta commons or some such, but i didn't pay
any attention. is it possible that something like that happened and
the maven build wasn't updated?

i just tried the ant build, and that went just fine (except for a test
failure), so yea, the problem must be specific to the maven build.

i noticed that the subprojects listed by the maven reactor did not
include i18n in any fashion, so i wonder if that dependency was just
never added to the maven build.

View raw message